Diagnostic System Requirements

The Diagnostic System is designed for IE 11, and the current release and minus 1 versions of Edge, Firefox, Chrome & Safari.

 

Details

Microsoft Internet Explorer 11. The system is tested with Internet Explorer 11.
Note: At present IE9 should also work for respondents but will reach EOL in April 2017

Mozilla Firefox 50 and 49. The system is tested with an up to date version of Firefox.

Google Chrome 54 and 53. The system is tested with an up to date version of Chrome.

Microsoft Edge 38 and 37. The system is not actively tested on Edge, however Edge is intended to be fully compatible with the WebKit layout engine used by Chrome.

Safari 10 and 9.1.3. The system is not actively tested on Safari, however Safari is intended to be fully compatible with the WebKit layout engine used by Chrome.

 

Tablet / Mobile usage

This is not officially supported, however design elements intended to make the respondent functionality compatible with mobile device browsers have been incorporated, and we would welcome opportunities to test in a production environment.